Author Topic: Oven Gimbal on Hylas 46  (Read 195 times)

0 Members and 1 Guest are viewing this topic.

Seven Iron

  • Newbie
  • *
  • Posts: 4
Re: Oven Gimbal on Hylas 46
« Reply #6 on: March 25, 2022, 01:27:20 PM »
Thanks to everyone that replied.  It appears Hylas may used the square ovens on the first few 46 hulls.  I knew moving the pivot point forward wouldn't gain me much and probably would just create more problems.  Having only owned a sailboat for just under two years, I hadn't even realized they made an angled back oven.  LOL!  Looks like I'll be swapping them out.  I really appreciate the Force 10 recommendation from Anthem, Ripple, & Ambition.  I owe you all a drink.  Joel, you're invited too! 

Chris
s/v Seven Iron   

Anthem

  • Newbie
  • *
  • Posts: 10
Re: Oven Gimbal on Hylas 46
« Reply #5 on: March 25, 2022, 06:04:17 AM »
We had same problem with H46-8.  Back of oven was square.  Moving pivot point would not have helped enough.  We sold that oven and bought a Force 10 - 63351 with angled back.

Ripple

  • Jr. Member
  • **
  • Posts: 91
Re: Oven Gimbal on Hylas 46
« Reply #4 on: March 24, 2022, 07:52:15 PM »
For reference, our force10 is 3-3/4

Ambition

  • Full Member
  • ***
  • Posts: 166
Re: Oven Gimbal on Hylas 46
« Reply #3 on: March 24, 2022, 04:21:26 PM »
Chris, we have a 46 #40 and we do not have teh same issue as you are describing. The entire unit is not a square box, the back is angled. Our unit was built by Force 10.

Merrill
S/V Ambition H46 #40

joel

  • Sr. Member
  • ****
  • Posts: 462
Re: Oven Gimbal on Hylas 46
« Reply #2 on: March 24, 2022, 03:53:36 AM »
Chris
Sounds like the pivot points need to be moved inboard. A PIA job, but simple enough   
Joel

Seven Iron

  • Newbie
  • *
  • Posts: 4
Oven Gimbal on Hylas 46
« Reply #1 on: March 24, 2022, 12:06:03 AM »
Hello everyone.  I bought a Hylas 46 in late 2020 (hull #9).  We brought her to NC from St Thomas last spring.  I haven't did an overnight since.  My issue is the stove/oven will gimbal fine on a starboard tack, but on a port tack, the bottom back of the stove hits the hull.  Even on a slight heel angle.  Basically, I can't cook when on a port tack.  Anyone else have this issue?  It appears to be the original unit, but not sure.  Trying to figure out a solution which may involve a new stove!

Chris
s/v Seven Iron

 

If you wish to help keep the HYOA running, please click the donation button below